Latest Chrome update causes playback errors for some videos on Mac/Windows

Incident Report for SundaySky

Resolved

This incident has been resolved.
Posted Oct 23, 2025 - 17:26 UTC

Identified

We've identified a video playback issue stemming from the latest Chrome updates, and the way Chrome now handles HLS streams by default. In the meantime, some videos may get errors upon playback. We will have a fix in place shortly.
Posted Oct 23, 2025 - 14:49 UTC
This incident affected: SundaySky Player.